West Virginia Delays

Incident Report for Asurint

Update

Please continue to expect potential delays as the state is still in the process of completing system upgrades. We will continue to monitor and provide updates.
Posted 3 days ago. Apr 01, 2025 - 09:26 EDT

Monitoring

Please expect potential delays in West Virginia due to system upgrades by the state. We will continue to monitor and provide updates.
Posted 21 days ago. Mar 14, 2025 - 10:48 EDT