Delays in Georgia

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 12:20 EST

Monitoring

Please expect delays due to intermittent website issues, primarily in; Coweta, Douglas. We will continue to monitor and provide updates.
Posted Dec 09, 2025 - 15:12 EST
This incident affected: Asurint | Background Screening Platform and Asurint | Tenant Screening Platform.