Delays in Texas

Incident Report for Asurint

Update

Please be advised of continued delays, primarily in Floyd and Jefferson Counties. These searches are clerk-assisted, and local courts are currently experiencing higher than usual volumes, which is contributing to slower turnaround times.
Posted Sep 10, 2025 - 10:21 EDT

Monitoring

Please expect delays, primarily in Floyd and Jefferson Counties. These searches are clerk-assisted, and local courts are currently experiencing higher than usual volumes, which is contributing to slower turnaround times.
Posted Sep 03, 2025 - 10:41 EDT
This incident affects: Asurint | Background Screening Platform.