eScreen Service Advisory

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 14:31 EDT

Investigating

eScreen is currently experiencing an outage impacting scheduling. You may encounter issues when attempting to schedule a service.

Our team is actively monitoring the situation in close coordination with eScreen and will provide updates as more information becomes available.
Posted Aug 13, 2026 - 14:21 EDT
This incident affected: Asurint | Background Screening Platform.