Investigating Order Placement Errors

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 15:16 EDT

Identified

We are currently investigating an issue impacting clients and candidates attempting to place orders. Users may experience errors or be unable to successfully submit orders at this time.

Our team is actively working to identify the root cause and restore normal service as quickly as possible.
Posted Jul 14, 2026 - 13:42 EDT
This incident affected: Asurint | Background Screening Platform.