Delays in Puerto Rico

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 10:31 EST

Monitoring

Please be advised that the Puerto Rico system is currently under maintenance. Per the clerks, no results will be provided today. We will continue to provide updates as they become available.
Posted Jan 09, 2026 - 14:40 EST
This incident affected: Asurint | Background Screening Platform.