Delays in South Carolina

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 10:24 EDT

Monitoring

Please be advised of continued delays in South Carolina. These searches are clerk-assisted, and local courts are currently experiencing higher than usual volumes, which is contributing to slower turnaround times.
Posted Aug 26, 2025 - 09:01 EDT

Identified

Please expect delays in South Carolina. These searches are clerk-assisted, and local courts are currently experiencing higher than usual volumes, which is contributing to slower turnaround times.
Posted Aug 19, 2025 - 15:07 EDT
This incident affected: Asurint | Background Screening Platform.