Court Closures – April 3, 2026 (Good Friday Observance)

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 09:26 EDT

Investigating

Please be advised that many courts across the country are closed today, April 3, 2026, in observance of Good Friday. As a result, delays may occur for searches requiring in‑person access or clerk assistance.
Posted Apr 03, 2026 - 10:33 EDT
This incident affected: Asurint | Background Screening Platform, Asurint | Client Integration API, Asurint | Tenant Screening Platform, Asurint | Tenant Client Integration API, Asurint | Insights, and Asurint | Customer Service Platform.