Delays in Ohio

Incident Report for Asurint

Update

Please be advised of continued delays due to website outages, primarily in; Butler County. We are actively monitoring the situation and will continue to provide updates.
Posted Oct 20, 2025 - 10:14 EDT

Investigating

Please expect potential delays in Ohio, primarily in the following counties; Butler, Franklin. due to website outages. We are actively monitoring the situation and will continue to provide updates.
Posted Sep 22, 2025 - 19:51 EDT
This incident affects: Asurint | Background Screening Platform, Asurint | Tenant Screening Platform, Asurint | Data Availability, Asurint | Insights, and Asurint | Customer Service Platform.