Delays in Louisiana
Incident Report for Asurint
Update
We are continuing to monitor the situation and will provide updates as they become available.
Posted Sep 17, 2024 - 08:43 EDT
Monitoring
Please expect delays in Louisiana due to Hurricane Francine. The following counties are currently closed:

Ascension, East Baton Rouge, Evangeline, Iberville, Jefferson Davis, Lafourche, Orleans, Plaquemines, Pointe Coupee, St Bernard, St Charles, St James, St John, St Mary, Tangipahoa, Terrebonne, & Vermillion

We will continue to monitor the situation closely and provide updates as they become available.
Posted Sep 12, 2024 - 17:19 EDT